Topic: poser .htaccess

was killed .htaccess.
restored from monstra-2.2.0.zip.
version cms 2.2.0

#
# Monstra CMS :: php & apache settings 
#

# Set default charset utf-8
AddDefaultCharset UTF-8

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
    php_flag magic_quotes_gpc                 off
    php_flag magic_quotes_sybase              off
    php_flag register_globals                 off
</IfModule>


# Setting rewrite rules.
<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /%siteurlhere%/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php [QSA,L]
</IfModule>

.htaccess rights are -rw-r--r--

Home app, and internal error climbs:

Bad request!

Your browser (or proxy) sent a request that this server could not understand.

If you think this is a server error, please contact the webmaster.

Error 400

rts-yar.ru
Sun Apr 21 15:43:11 2013
Apache/2.2.23 (Gentoo) mod_dp/0.99.6 Phusion_Passenger/2.2.15 PHP/5.2.17-pl0-gentoo mod_wsgi/3.3 Python/2.7.2

help please!

Re: poser .htaccess

decided

#
# Monstra CMS :: php & apache settings 
#

# Set default charset utf-8
AddDefaultCharset UTF-8

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
    php_flag magic_quotes_gpc                 off
    php_flag magic_quotes_sybase              off
    php_flag register_globals                 off
</IfModule>


# Setting rewrite rules.
<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php [QSA,L]
</IfModule>

RewriteEngine On
RewriteCond %{HTTP_HOST} ^www.site.ru$ [NC]
RewriteRule ^(.*)$ http://site.ru/$1 [R=301,L]

Re: poser .htaccess

Thank You @yar.ru
I've faced similar problem on one of my client's server and Your .htaccess helped me - it works super !!!!