1 (edited by barichello 2015-09-21 10:26:16)

Topic: (solved) Problems after changing php.ini

I made a few changes in my php.ini and .htaccess because of other app I have running in my server. After some days I realized that it has impacted Monstra and I can't figured out which configuration did this.

Is there anybody using monstra and php 5.3.14? Could you send me your php.ini?

Re: (solved) Problems after changing php.ini

what problem you have;

Here you will find templates for monstra and morfy xxwebplus
Best cms

Re: (solved) Problems after changing php.ini

For example, after I log on and access the dashboard, all links available on that screen are working, except the "File" (it loads a blank screen).

Also, i can create a page, but the system is not saving it.

Re: (solved) Problems after changing php.ini

copy whole .htaccess file and paste here

Here you will find templates for monstra and morfy xxwebplus
Best cms

Re: (solved) Problems after changing php.ini

Default php ini 5.3
http://xxwebplus.eu/php-ini

Here you will find templates for monstra and morfy xxwebplus
Best cms

Re: (solved) Problems after changing php.ini

I think that the problem is not from php ini but in .htaccess

Here you will find templates for monstra and morfy xxwebplus
Best cms

Re: (solved) Problems after changing php.ini

Maybe... I also changed the .htaccess. This is the .htaccess in the folder where Monstra is installed:

suPHP_ConfigPath /home/mais6/public_html/coffee
AddHandler php53-script .php

#
# Monstra CMS :: php & apache settings 
#

# Set default charset utf-8
AddDefaultCharset UTF-8

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
    php_flag magic_quotes_gpc                 off
    php_flag magic_quotes_sybase              off
    php_flag register_globals                 off
</IfModule>


# Setting rewrite rules.
<IfModule mod_rewrite.c>
    RewriteEngine on
    
    # Update code bellow for SEO improvements 
    # RewriteCond %{HTTP_HOST} ^www.example.org [NC]
     # RewriteRule ^(.*)$ http://example.org/$1 [R=301,L]
    
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php [QSA,L]
    
    # Update code bellow for SEO improvements 
    # Redirect 301 /home http://example.org/
</IfModule>

Re: (solved) Problems after changing php.ini

changed
from

suPHP_ConfigPath /home/mais6/public_html/coffee
AddHandler php53-script .php

#
# Monstra CMS :: php & apache settings 
#

# Set default charset utf-8
AddDefaultCharset UTF-8

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
    php_flag magic_quotes_gpc                 off
    php_flag magic_quotes_sybase              off
    php_flag register_globals                 off
</IfModule>


# Setting rewrite rules.
<IfModule mod_rewrite.c>
    RewriteEngine on
    
    # Update code bellow for SEO improvements 
    # RewriteCond %{HTTP_HOST} ^www.example.org [NC]
     # RewriteRule ^(.*)$ http://example.org/$1 [R=301,L]
    
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php [QSA,L]
    
    # Update code bellow for SEO improvements 
    # Redirect 301 /home http://example.org/
</IfModule>

in

# Use PHP 5.3
AddType application/x-httpd-php53 .php

#
# Monstra CMS :: php & apache settings 
#

# Set default charset utf-8
AddDefaultCharset UTF-8

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
    php_flag magic_quotes_gpc                 off
    php_flag magic_quotes_sybase              off
    php_flag register_globals                 off
</IfModule>


# Setting rewrite rules.
<IfModule mod_rewrite.c>
    RewriteEngine on
    
    # Update code bellow for SEO improvements 
    # RewriteCond %{HTTP_HOST} ^www.example.org [NC]
     # RewriteRule ^(.*)$ http://example.org/$1 [R=301,L]
    
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php [QSA,L]
    
    # Update code bellow for SEO improvements 
    # Redirect 301 /home http://example.org/
</IfModule>
Here you will find templates for monstra and morfy xxwebplus
Best cms

Re: (solved) Problems after changing php.ini

The problem continues the same...

What about the finals below on php.ini? I know that I changed it but,m being honest, I cant remember what were the original values sad

register_globals = On
register_long_arrays = On

Re: (solved) Problems after changing php.ini

register_globals = off
register_long_arrays = off

Update on the progress
now will work wink

Here you will find templates for monstra and morfy xxwebplus
Best cms

Re: (solved) Problems after changing php.ini

No... sad

Re: (solved) Problems after changing php.ini

ok you want to take a look at your files;
if so please email me through the contact form passwords for ftp
http://xxwebplus.eu/contact

Here you will find templates for monstra and morfy xxwebplus
Best cms

Re: (solved) Problems after changing php.ini

Problem solved after xxwebplus reinstalled Monstra for me.
Thank you, man!

Re: (solved) Problems after changing php.ini

wink

Here you will find templates for monstra and morfy xxwebplus
Best cms

Re: (solved) Problems after changing php.ini

I am pretty sure the problem was with the .htaccess file at all! wink

Re: (solved) Problems after changing php.ini

Hi patco,
and I thought that the problem would be by .htaccess NO!
the problem was to php.ini wink

Here you will find templates for monstra and morfy xxwebplus
Best cms